Heroku Changelog Rubygems upgrade for Ruby 2.0.0

Change effective on 19 April 2013

Rubygems on Ruby 2.0.0 has been upgraded from Rubygems 2.0.0 to Rubygems 2.0.3 to fix a bug with native extension compilation like bson_ext.