Heroku-18 and Heroku-20 Stack Images Updated

Change effective on 20 May 2022

We have updated the heroku-18 and heroku-20 stack images to pick up security fixes in upstream packages. The new stack images will be rolled out automatically over the next 24 hours. You do not need to redeploy your app or manually restart your dynos.

See this Dev Center article for an overview of the packages available in each stack image.

Changelog of packages

The following packages have been changed; a separate section for each stack (if applicable) lists packages that are only available at build time, but not at runtime.

Stack: heroku-18

  • Updated bash from version 4.4.18-2ubuntu1.2 to 4.4.18-2ubuntu1.3
  • Updated curl from version 7.58.0-2ubuntu3.16 to 7.58.0-2ubuntu3.18
  • Updated distro-info-data from version 0.37ubuntu0.13 to 0.37ubuntu0.14
  • Updated ghostscript from version 9.26~dfsg+0-0ubuntu0.18.04.15 to 9.26~dfsg+0-0ubuntu0.18.04.16
  • Updated git from version 1:2.17.1-1ubuntu0.9 to 1:2.17.1-1ubuntu0.11
  • Updated git-man from version 1:2.17.1-1ubuntu0.9 to 1:2.17.1-1ubuntu0.11
  • Updated gzip from version 1.6-5ubuntu1.1 to 1.6-5ubuntu1.2
  • Updated libcurl3-gnutls from version 7.58.0-2ubuntu3.16 to 7.58.0-2ubuntu3.18
  • Updated libcurl4 from version 7.58.0-2ubuntu3.16 to 7.58.0-2ubuntu3.18
  • Updated libdbus-1-3 from version 1.12.2-1ubuntu1.2 to 1.12.2-1ubuntu1.3
  • Updated libgs9 from version 9.26~dfsg+0-0ubuntu0.18.04.15 to 9.26~dfsg+0-0ubuntu0.18.04.16
  • Updated libgs9-common from version 9.26~dfsg+0-0ubuntu0.18.04.15 to 9.26~dfsg+0-0ubuntu0.18.04.16
  • Updated libkeyutils1 from version 1.5.9-9.2ubuntu2 to 1.5.9-9.2ubuntu2.1
  • Updated libldap-2.4-2 from version 2.4.45+dfsg-1ubuntu1.10 to 2.4.45+dfsg-1ubuntu1.11
  • Updated libldap-common from version 2.4.45+dfsg-1ubuntu1.10 to 2.4.45+dfsg-1ubuntu1.11
  • Updated liblzma5 from version 5.2.2-1.3 to 5.2.2-1.3ubuntu0.1
  • Updated libmysqlclient20 from version 5.7.37-0ubuntu0.18.04.1 to 5.7.38-0ubuntu0.18.04.1
  • Updated libpcre3 from version 2:8.39-9 to 2:8.39-9ubuntu0.1
  • Updated libpq5 from version 14.2-1.pgdg18.04+1 to 14.3-1.pgdg18.04+1
  • Updated libsepol1 from version 2.7-1 to 2.7-1ubuntu0.1
  • Updated libsqlite3-0 from version 3.22.0-1ubuntu0.4 to 3.22.0-1ubuntu0.5
  • Updated libssl1.0.0 from version 1.0.2n-1ubuntu5.8 to 1.0.2n-1ubuntu5.9
  • Updated libssl1.1 from version 1.1.1-1ubuntu2.1~18.04.15 to 1.1.1-1ubuntu2.1~18.04.17
  • Updated libtiff5 from version 4.0.9-5ubuntu0.4 to 4.0.9-5ubuntu0.5
  • Updated libxml2 from version 2.9.4+dfsg1-6.1ubuntu1.5 to 2.9.4+dfsg1-6.1ubuntu1.6
  • Updated linux-libc-dev from version 4.15.0-175.184 to 4.15.0-177.186
  • Updated openssh-client from version 1:7.6p1-4ubuntu0.6 to 1:7.6p1-4ubuntu0.7
  • Updated openssh-server from version 1:7.6p1-4ubuntu0.6 to 1:7.6p1-4ubuntu0.7
  • Updated openssh-sftp-server from version 1:7.6p1-4ubuntu0.6 to 1:7.6p1-4ubuntu0.7
  • Updated openssl from version 1.1.1-1ubuntu2.1~18.04.15 to 1.1.1-1ubuntu2.1~18.04.17
  • Updated postgresql-client-14 from version 14.2-1.pgdg18.04+1 to 14.3-1.pgdg18.04+1
  • Updated postgresql-client-common from version 238.pgdg18.04+1 to 241.pgdg18.04+1
  • Updated xz-utils from version 5.2.2-1.3 to 5.2.2-1.3ubuntu0.1

Updates to packages available at build time only

  • Updated libcurl4-openssl-dev from version 7.58.0-2ubuntu3.16 to 7.58.0-2ubuntu3.18
  • Updated libgs-dev from version 9.26~dfsg+0-0ubuntu0.18.04.15 to 9.26~dfsg+0-0ubuntu0.18.04.16
  • Updated libkeyutils-dev from version 1.5.9-9.2ubuntu2 to 1.5.9-9.2ubuntu2.1
  • Updated libldap2-dev from version 2.4.45+dfsg-1ubuntu1.10 to 2.4.45+dfsg-1ubuntu1.11
  • Updated liblzma-dev from version 5.2.2-1.3 to 5.2.2-1.3ubuntu0.1
  • Updated libmysqlclient-dev from version 5.7.37-0ubuntu0.18.04.1 to 5.7.38-0ubuntu0.18.04.1
  • Updated libpcre16-3 from version 2:8.39-9 to 2:8.39-9ubuntu0.1
  • Updated libpcre3-dev from version 2:8.39-9 to 2:8.39-9ubuntu0.1
  • Updated libpcre32-3 from version 2:8.39-9 to 2:8.39-9ubuntu0.1
  • Updated libpcrecpp0v5 from version 2:8.39-9 to 2:8.39-9ubuntu0.1
  • Updated libpq-dev from version 14.2-1.pgdg18.04+1 to 14.3-1.pgdg18.04+1
  • Updated libsepol1-dev from version 2.7-1 to 2.7-1ubuntu0.1
  • Updated libssl-dev from version 1.1.1-1ubuntu2.1~18.04.15 to 1.1.1-1ubuntu2.1~18.04.17
  • Updated libtiff-dev from version 4.0.9-5ubuntu0.4 to 4.0.9-5ubuntu0.5
  • Updated libtiff5-dev from version 4.0.9-5ubuntu0.4 to 4.0.9-5ubuntu0.5
  • Updated libtiffxx5 from version 4.0.9-5ubuntu0.4 to 4.0.9-5ubuntu0.5
  • Updated libxml2-dev from version 2.9.4+dfsg1-6.1ubuntu1.5 to 2.9.4+dfsg1-6.1ubuntu1.6
  • Updated postgresql-common from version 238.pgdg18.04+1 to 241.pgdg18.04+1
  • Updated postgresql-server-dev-14 from version 14.2-1.pgdg18.04+1 to 14.3-1.pgdg18.04+1

Stack: heroku-20

  • Updated apt from version 2.0.6 to 2.0.8
  • Updated apt-transport-https from version 2.0.6 to 2.0.8
  • Updated apt-utils from version 2.0.6 to 2.0.8
  • Updated bash from version 5.0-6ubuntu1.1 to 5.0-6ubuntu1.2
  • Updated curl from version 7.68.0-1ubuntu2.7 to 7.68.0-1ubuntu2.11
  • Updated distro-info-data from version 0.43ubuntu1.9 to 0.43ubuntu1.10
  • Updated git from version 1:2.25.1-1ubuntu3.2 to 1:2.25.1-1ubuntu3.4
  • Updated git-man from version 1:2.25.1-1ubuntu3.2 to 1:2.25.1-1ubuntu3.4
  • Updated gzip from version 1.10-0ubuntu4 to 1.10-0ubuntu4.1
  • Updated libapt-pkg6.0 from version 2.0.6 to 2.0.8
  • Updated libc-bin from version 2.31-0ubuntu9.7 to 2.31-0ubuntu9.9
  • Updated libc-dev-bin from version 2.31-0ubuntu9.7 to 2.31-0ubuntu9.9
  • Updated libc6 from version 2.31-0ubuntu9.7 to 2.31-0ubuntu9.9
  • Updated libc6-dev from version 2.31-0ubuntu9.7 to 2.31-0ubuntu9.9
  • Updated libcurl3-gnutls from version 7.68.0-1ubuntu2.7 to 7.68.0-1ubuntu2.11
  • Updated libcurl4 from version 7.68.0-1ubuntu2.7 to 7.68.0-1ubuntu2.11
  • Updated libdbus-1-3 from version 1.12.16-2ubuntu2.1 to 1.12.16-2ubuntu2.2
  • Updated libfribidi0 from version 1.0.8-2 to 1.0.8-2ubuntu0.1
  • Updated libldap-2.4-2 from version 2.4.49+dfsg-2ubuntu1.8 to 2.4.49+dfsg-2ubuntu1.9
  • Updated libldap-common from version 2.4.49+dfsg-2ubuntu1.8 to 2.4.49+dfsg-2ubuntu1.9
  • Updated liblzma5 from version 5.2.4-1ubuntu1 to 5.2.4-1ubuntu1.1
  • Updated libmysqlclient21 from version 8.0.28-0ubuntu0.20.04.3 to 8.0.29-0ubuntu0.20.04.3
  • Updated libpcre3 from version 2:8.39-12build1 to 2:8.39-12ubuntu0.1
  • Updated libpq5 from version 14.2-1.pgdg20.04+1+b1 to 14.3-1.pgdg20.04+1
  • Updated libsepol1 from version 3.0-1 to 3.0-1ubuntu0.1
  • Updated libsqlite3-0 from version 3.31.1-4ubuntu0.2 to 3.31.1-4ubuntu0.3
  • Updated libssl1.1 from version 1.1.1f-1ubuntu2.12 to 1.1.1f-1ubuntu2.13
  • Updated libsystemd0 from version 245.4-4ubuntu3.15 to 245.4-4ubuntu3.17
  • Updated libtiff5 from version 4.1.0+git191117-2ubuntu0.20.04.2 to 4.1.0+git191117-2ubuntu0.20.04.3
  • Updated libudev1 from version 245.4-4ubuntu3.15 to 245.4-4ubuntu3.17
  • Updated libxml2 from version 2.9.10+dfsg-5ubuntu0.20.04.2 to 2.9.10+dfsg-5ubuntu0.20.04.3
  • Updated linux-libc-dev from version 5.4.0-107.121 to 5.4.0-110.124
  • Updated locales from version 2.31-0ubuntu9.7 to 2.31-0ubuntu9.9
  • Updated openssh-client from version 1:8.2p1-4ubuntu0.4 to 1:8.2p1-4ubuntu0.5
  • Updated openssh-server from version 1:8.2p1-4ubuntu0.4 to 1:8.2p1-4ubuntu0.5
  • Updated openssh-sftp-server from version 1:8.2p1-4ubuntu0.4 to 1:8.2p1-4ubuntu0.5
  • Updated openssl from version 1.1.1f-1ubuntu2.12 to 1.1.1f-1ubuntu2.13
  • Updated postgresql-client-14 from version 14.2-1.pgdg20.04+1+b1 to 14.3-1.pgdg20.04+1
  • Updated postgresql-client-common from version 238.pgdg20.04+1 to 241.pgdg20.04+1
  • Updated xz-utils from version 5.2.4-1ubuntu1 to 5.2.4-1ubuntu1.1

Updates to packages available at build time only

  • Updated libapt-pkg-dev from version 2.0.6 to 2.0.8
  • Updated libarchive13 from version 3.4.0-2ubuntu1.1 to 3.4.0-2ubuntu1.2
  • Updated libc6-i386 from version 2.31-0ubuntu9.7 to 2.31-0ubuntu9.9
  • Updated libcurl4-openssl-dev from version 7.68.0-1ubuntu2.7 to 7.68.0-1ubuntu2.11
  • Updated libldap2-dev from version 2.4.49+dfsg-2ubuntu1.8 to 2.4.49+dfsg-2ubuntu1.9
  • Updated liblzma-dev from version 5.2.4-1ubuntu1 to 5.2.4-1ubuntu1.1
  • Updated libmysqlclient-dev from version 8.0.28-0ubuntu0.20.04.3 to 8.0.29-0ubuntu0.20.04.3
  • Updated libpcre16-3 from version 2:8.39-12build1 to 2:8.39-12ubuntu0.1
  • Updated libpcre3-dev from version 2:8.39-12build1 to 2:8.39-12ubuntu0.1
  • Updated libpcre32-3 from version 2:8.39-12build1 to 2:8.39-12ubuntu0.1
  • Updated libpcrecpp0v5 from version 2:8.39-12build1 to 2:8.39-12ubuntu0.1
  • Updated libpq-dev from version 14.2-1.pgdg20.04+1+b1 to 14.3-1.pgdg20.04+1
  • Updated libsepol1-dev from version 3.0-1 to 3.0-1ubuntu0.1
  • Updated libssl-dev from version 1.1.1f-1ubuntu2.12 to 1.1.1f-1ubuntu2.13
  • Updated libsystemd-dev from version 245.4-4ubuntu3.15 to 245.4-4ubuntu3.17
  • Updated libtiff-dev from version 4.1.0+git191117-2ubuntu0.20.04.2 to 4.1.0+git191117-2ubuntu0.20.04.3
  • Updated libtiffxx5 from version 4.1.0+git191117-2ubuntu0.20.04.2 to 4.1.0+git191117-2ubuntu0.20.04.3
  • Updated libudev-dev from version 245.4-4ubuntu3.15 to 245.4-4ubuntu3.17
  • Updated libxml2-dev from version 2.9.10+dfsg-5ubuntu0.20.04.2 to 2.9.10+dfsg-5ubuntu0.20.04.3
  • Updated postgresql-common from version 238.pgdg20.04+1 to 241.pgdg20.04+1
  • Updated postgresql-server-dev-14 from version 14.2-1.pgdg20.04+1+b1 to 14.3-1.pgdg20.04+1