Heroku Changelog Ruby applications now use Bundler 1.2.1

Change effective on 20 September 2012

Upgraded the Ruby buildpack to use Bundler 1.2.1 which includes fixes to bundle clean and resilience to the recent rubygems.org issues.