Heroku Changelog Going forwards any deploys of JRuby 1.7.1, 1.7.2, and 1.7.3 will use OpenJDK 1.7.0_25.

Change effective on 29 October 2013

JRuby 1.7.1, 1.7.2, & 1.7.3 experience a libjffi-1.2.so warning if a they are used with a version OpenJDK 1.7.0_45 or later. Going forwards any deploys of JRuby 1.7.1, 1.7.2, and 1.7.3 will use OpenJDK 1.7.0_25.