Change effective on 15 March 2019
A patch was released by RubyGems core to allow the version of RubyGems that ships with Ruby 2.5.x to work with Bundler 2.x.
This patch fixes an issue that is documented as a known issue in bundler 2.0.1. The problem comes when a version that does not match the exact Bundler version on the platform is used. For example, if an application specifies 2.0.0, but Heroku provides 2.0.1 then an error would be incorrectly raised. The patch fixes this behavior.
To get this patch, re-deploy your application with one of these versions:
Please note that while all 2.5.x versions were patched, you should upgrade to the latest patch version of 2.5 as soon as possible which is 2.5.5. We do not officially support any versions other than 2.5.5.
Ruby 2.5.5 is already using an updated version of RubyGems and does not require this patch. Ruby 2.5.4 was not patched since it contains a bug that prevents it from being used on the platform.